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Introduction

eCognition Developer 8.64.0

Trimble eCognition is a comprehensive image analysis platform for multi-dimensional
image analysis. It contains all the client and server software needed to extract intelligence
from any digital image in a fully or semi-automated way.

The client software is role-based and supports the needs and skills of different users in
an organization. The server software, known as the eCognition Server, is a processing
environment that allows the batch processing of jobs and is hugely scalable, capable of
handling tens, hundreds or many thousands of images in a single job.

Figure 1. eCognition multi-dimensional image analysis software
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2 eCognition 8.64.0 for Windows

Client Software

eCognition Developer 8.64.0

eCognition Developer 8.64.0 is a powerful and completely integrated environment de-
signed for image analysis specialists to develop, test and package new image analysis
applications. eCognition Developer 8.64.0 can be used as a standalone tool or in combi-
nation with the eCognition Server.

eCognition Developer 8.64.0 incorporates the latest generation of Definiens Cogni-
tion Network Technology®, enabling the creation of new solutions for multidimen-
sional image analysis applications. It incorporates a new programming paradigm, high-
performance analysis for complex multidimensional data and sophisticated viewing, vi-
sualization and registration capabilities.

eCognition Architect 8.64.0

eCognition Architect 8.64.0 is an intuitive end-user tool used to configure and execute
image analysis applications. It provides support for fully automated or semi-automated
workflows and guides users through the application they are running. eCognition Ar-
chitect 8.64.0 incorporates all the required tools for users to import, view and visualize
multidimensional images and results.

Server Software

eCognition Server

eCognition Server provides a processing environment for the batch execution of image
analysis using a high-performance grid computing environment. The eCognition Server
includes specific components designed to meet the needs of the multidimensional image
analysis required for cell, tissue and non-invasive imaging in life sciences and healthcare.

Supported connectors and drivers are described in a separate document, Supported Con-
nectors and File Drivers.

Administration Console

The Administration Console provides system administrators with a web-based interface
that simplifies the management of the eCognition Server environment.

Data Management

eCognition Data Management offers an open, enterprise-ready and cost-effective solu-
tion for managing the huge volume of data generated by image analysis projects. The
data is managed using standard relational database technologies and can be used with all
eCognition products.

30 November 2010 Installation and Administration Guide



Introduction 3

Integration Software

Software Development Kit (SDK)

The Software Development Kit (SDK) enables the integration of the eCognition products
within any business process using any data source or target, and allows the core analysis
capabilities of the eCognition Server to be extended.

Installation and Administration Guide 30 November 2010





1 Setting Up an eCognition®

System

1.1 Overview of the eCognition System

The eCognition Server is a scalable grid computing infrastructure that may be installed
on one or more machines in your network.

Each machine that hosts components of eCognition 8.64.0 is called a node. A typical
eCognition 8.64.0 setup consists of a primary node and one or more processing nodes.
While the primary node controls the operation of the server, the processing nodes perform
the image analysis tasks.

Figure 1.1. eCognition client-server setup

1.1.1 Primary Nodes

The primary node hosts the infrastructure components required to operate the eCognition
Server:

5



6 eCognition 8.64.0 for Windows

• Administration Server: Application server of the Administration Console
• Deployment Server: Manages and distributes image analysis software packages
• Job Scheduler: Manages and distributes active user jobs for processing nodes
• Spooler Service: Retrieves analysis results from processing nodes and stores them

in a relational database (part of eCognition Data Management)

Figure 1.2. Components on the primary node of the eCognition Server

1.1.2 Processing Nodes

The processing nodes host the processing components required to perform the image
analysis service:

• The Configuration Service configures the Analysis Engine according to the require-
ments of the image analysis tasks. It downloads new packages from the deployment
server if required

• The Analysis Engine performs the image analysis tasks.

If you use multi-processor or multi-core machines, you can set up processing nodes with
more than one analysis engine. Each analysis engine should then have a dedicated CPU
core and one eCognition Server CPU license is needed per analysis engine. It is also
possible to install analysis engines on the primary node and use it as a processing node.
In this case, the deployment server also acts as the configuration service for this machine.

Figure 1.3. Components on a processing node of the eCognition Server

Control Service

The Control Service is a small component that runs on each node of the eCognition Server.
It starts and monitors the other eCognition components of the respective node.
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Setting Up an eCognition® System 7

1.1.3 Image File and Results Access

To process images, Analysis Engines require access to image data files. This access can
be direct, using network shares, or can be via the Image Proxy Server. We recommend
you install the Image Proxy Server to improve the performance and reliability of image
access.

The Image Proxy Server

The Image Proxy Server (IPS) is a Windows software component that provides high-
performance image access and caching. A local IPS is installed automatically with each
eCognition client.

Figure 1.4. Recommended Client-Server Configuration

The key functionality provided by the IPS includes.

• Delivering Windows-only file formats to Linux eCognition Server (requires one
Windows server)

• Creating and delivering zoom pyramids for large images
• Creating and delivering thumbnail caches for workspaces
• Creating and delivering an image statistics cache
• Creating and delivering cached zoom pyramids for thematic layers
• Creating and delivering cached raster representations of vector files.

Data Storage and Cache Management The Image Proxy Server creates and manages
cache data, which can be stored in a sub folder with the original data or in a central-
ized repository connected to the Image Proxy Server (local disk or NAS). This cache can
be sized appropriately for your environment. It uses a combination of maximum size,
FIFO and minimum and maximum retention times. This caching can also be turned off
by updating the default configuration.
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8 eCognition 8.64.0 for Windows

File Server

A file server is required to store source images, working files (workspaces and projects)
and exported results.

Client Access to the File Server All clients should have read/write access to the file
server.

Server Access to the File Server A file server is required to store analysis results and to
provide access to the source image data (either via the Image Proxy Server or by direct file
access). All processing nodes and the Image Proxy Server should have read/write access
to the file server. This can be achieved using file sharing in Windows environments and
NFS mount points for Linux operating systems.

Image Proxy Server Access to the File Server If the file server is a high-performance
NAS/SAN then it may also be used to store the centralized cache from the Image Proxy
Server. In this case, read/write access is required from the Image Proxy Server to the file
server.

Interprocess Communication

The communication protocol for the components of the eCognition Developer 8.64.0 soft-
ware suite is SOAP-based. All ports used by the system must be available and properly
configured with respect to virus scanners and firewalls.

Administration Console

The eCognition Administration Console provides system administrators with a web-
based interface that simplifies the management of the eCognition 8.64.0 environment.
It is installed as a central part of eCognition Server and can be accessed by any machine
in the network connected to the server.

License Server

The eCognition License Server software provides software licenses for eCognition prod-
ucts. It can be installed on any machine that is reliably available within the network
domain used to operate eCognition software.

1.2 Installation Workflow

To set up a full client-server eCognition system from scratch:

1. Install the License Server software. It can be installed on any machine that is reli-
ably available within the network domain used to operate the eCognition software
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Setting Up an eCognition® System 9

2. Install eCognition software on the host machine for the primary node of the eCog-
nition Server. By default, one processing unit will be installed on the primary node.
This ensures that the server can be used to process image analysis jobs directly
after installation

3. Install the Image Proxy Server on the designated host machine and configure the
primary nodes to communicate with it

4. Install the Administration Control, to deploy additional distributed processing
nodes (as appropriate)

5. Install eCognition clients on users’ desktop PCs and configure them to point to the
Image Proxy Server

6. Test your installation.

1.2.1 Configuring the eCognition Server for Distributed Processing

If you want to extend your processing capacity you can install and configure additional
processing nodes for the eCognition Server. To do this, install processing node software
on the processing nodes of the eCognition Server using the web-based Administration
Console.

1.2.2 Setting up Data Management (optional)

To set up eCognition Data Management you must prepare a database, and set up and
configure open database connectivity (ODBC).

1.3 Things You Need for the Installation

1.3.1 Installation Files

Installation files can be downloaded from the customer support download center. You
can contact support@ecognition.com for login details to the support area. All files are
contained within .zip archives and must be extracted before use.

• License Server <Version number> Setup.exe file for the installation of the eCogni-
tion License Server Software (for example: License Server v1.0.0 Setup.exe)

• Setup.exe file for the installation of the for the installation of the eCognition Grid
infrastructure software

• Setup.exe file for the installation of Image Proxy Server software
• One setup.exe file for each copy of the eCognition client.

1.3.2 License Activation ID

An activation ID is included in an entitlement certificate, which is emailed to customers.
The entitlement certificate lists all activation IDs for the ordered products. According to
the number of ordered products, each activation ID provides equivalent activation units.

Installation and Administration Guide 30 November 2010
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10 eCognition 8.64.0 for Windows

1.3.3 Network User Accounts and User Rights

The installation requires a working network connection. Make sure you have a valid user
account with the appropriate user rights as listed below.

License Server Software

• Local administrator rights
• Service installation rights

eCognition Server

• Local administrator rights:
– Read/write access to the hidden shares (c$, d$,. . . ) including the installation

path of the engine
– Service installation rights
– User administration rights

• User rights needed by the control service on every machine:
– Access to file storage for image data, results, workspaces, projects and rule

sets
– Login rights as service right on all processing node machines. This right is

assigned during the installation process
– Read/write access to the logs directory. This right is assigned during the

installation process
– Read access to the installation directory of the software
– Read/write access to the temp directory

eCognition Developer 8.64.0 Clients

• Software installation rights

1.4 Installing License Server Software

This section describes the steps for installing License Server Software.

1. After downloading and extracting a .zip file containing a License Server<Version
number>Setup.exe installation file, start the installation by double-clicking the file,
which launches the setup wizard. Press Next to proceed

2. Select, “I accept the terms in the License Agreement” to proceed to the next screen
3. In the Activation Options box, there are three choices:

• Activate Licenses: The License Server software will not be reinstalled. Use
this if you want to install a new type of license to be distributed by this license
server:

• Reinstall: Use this if you want to reinstall the existing license server without
license activation. You do not need to reactivate already existing licenses

• Full Install: Use this if you want to reinstall the existing license server and
create additional licenses. You do not need to reactivate already existing li-
censes
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4. The Activation Options box is displayed below:
• Enter the Activation ID you received from eCognition
• If you ordered multiple licenses, you may enter the number of licenses you

want to install during this installation procedure.
• A. Select Create Activation Request to save an activation request as file. Click

the Select File button to determine the file location. After saving click Next >
to exit the installation.

• Send the saved activation request file by e-mail to license@ecognition.com.
Trimble will email a license file to you

• After receiving license file by e-mail, save it on the hard disk of the machine
hosting the License Server software. Restart this installation procedure at
step 1 and proceed to step 4. Select Activate Licenses and continue with the
following step 8.

• Select License File and click the Select File button to determine the file loca-
tion.
You will be notified if your application was successful

5. The License Server 6.0 Setup box lets you choose the Start menu folder where the
program’s shortcuts will be copied. Alternatively, enter a new name to create a new
folder

6. Choose the destination folder for the installation. The default location is
C:/Program Files. If you prefer to use a different folder click Browse. . . to se-
lect another. Click Install to execute the installation

7. The installation progress is displayed in the status area. This information is saved
at the install.log file. You can find this file in the installation directory. The
default path is C:\Program Files\eCognition<Client or component name, Version
number>\Install.log. Alternatively, you can save the installation details by right-
clicking in the status area for the context menu to appear and choosing Copy De-
tails To Clipboard. Then you can open a text editor and paste the text from the
clipboard.

8. Upon successful completion, click Finish to close and exit the setup process.

1.5 Installing the eCognition 8.64.0 Client

The steps for installing the eCognition 8.64.0 client is essentially the same as installing
the license server. There are two differences:

The Licensing Information dialog box offers three options:

1. Select ‘set licensing later’ if currently there is no license available (this can be
installed at a later stage)

2. Select ‘localhost’ if the License Server software has been installed on the current
machine

3. Select ‘network’ to access the License Server software on a network. Browse the
network for the license server.

Alternatively you can type a computer name or an IP address – if you use a computer
name, ensure it can be resolved to an IP address.

• Selecting eCognition 8.64.0 installs the client software
• Selecting SDK installs the software development kit for eCognition 8.64.0

Installation and Administration Guide 30 November 2010
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• Documentation installs copies of the User Guide and Installation Guide
• Examples installs tutorials and examples for training and self-study.

Figure 1.5. The Choose Components dialog box lets you do a customized install

1.5.1 Starting the eCognition 8.64.0 Client

Figure 1.6. Start-up options for eCognition Developer 8.64.0

Selecting Rule Set Mode will take you to the standard developer environment. For simple
analysis tasks, you may wish to try Quick Map Mode.

Click any portal item to stop automatic opening. If you do not click a portal within three
seconds, the most recently used portal will start. To start a different portal, close the client
and start again.
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1.5.2 Configuring a Central Image Proxy Server

If you have decided to install a centralized Image Proxy Server you will need to update
the client’s configuration settings to point to the central server rather than the default
local server. To do this, go to Tools > Manage Local Servers in the client to bring up the
Manage Local Servers dialog. In the Central IPS Location field, enter the Image Proxy
Server name and port (for example pe1855n011:8386)

Display Colors Status Solution

Green-
Red

Control service running.
But the image server is not
reachable.

Go to Tools > Manage Local Servers >
Restart. This will stop and restart the control
service and the image proxy. Make sure the
Use Image Proxy checkbox is ticked. If the
server still fails to start, check the Central
IPS Location in the Manage Local Servers
dialog box (Tools > Manage Local Servers).
You can use the Start IPS Monitor button to
start the Image Proxy Server Monitor from
the client.

Green-
Green

Control service running
and current project or
workspace created using
the image server (which is
contactable).

Nothing, everything is normal.

Green-
Yellow

Control Service is running
but project or workspace
was created without the
Image Proxy Server.

Select Workspace or Select Project(s).
Go to Tools > Image Proxy Project
Conversion
Warning: If you are unsure do not convert
the project or workspace as this is a one way
operation and these workspaces cannot be
opened in previous versions of the software.

Red-
Green

Control service is not
running but image proxy
service is.

Go to Tools > Remove Image Proxy
Conversion. This will stop and restart both
the control service and the image proxy.
Make sure the Use Image Proxy Server
checkbox is ticked.

Red-Red Neither the local server or
the Image Proxy Server
has been started.

Go to Tools > Manage Local Servers > Start.
This will start the control service and the
Image Proxy Server. Make sure the Use
Image Proxy Server checkbox is ticked.

1.6 Installing the eCognition Server

This section describes the steps for installing the eCognition Grid Server Software.
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1. Download and extract the .zip file containing the Setup.exe installation file. Double-
click it to start the installation

2. In the License Agreement window, select “I accept the terms in the License Agree-
ment”

3. Connect to the license. Select “set licensing later” 1 if you wish to install the
License Server software later.

• Select Local Host if the License Server software has been installed on the
current machine.

• Select Network to access the License Server software on a network. Browse
the network for the license server.\\ Alternatively you can type a computer
name or an IP address.

4. In the Choose Start Menu Folder, you can change the folder where the Start menu
shortcuts will be located

5. In the Administration Console, select the destination folder that uses the Adminis-
tration Console as storage. If you prefer to use a different folder click the ellipsis
button and select another folder

6. In the Application User dialog box, type the username and password you wish to
use

7. The installation progress is displayed in the status area. This information is saved
at the install.log file, which you can find in the installation directory. The de-
fault path is C:\Program Files\eCognition<Client or component name, Version
number>\Install.log. Alternatively, you can save the installation details by right-
clicking in the status area of the dialog box and choosing Copy Details To Clip-
board. Then you can open a text editor and paste the text from the clipboard

8. When the installation is complete, click Finish.

1.7 Configuring the eCognition Server for Distributed
Processing

After the installation has finished successfully, the eCognition Server is ready for process-
ing analysis jobs received from clients. However, it is using only one CPU on the primary
node. If you want to extend your processing capacities you can add additional processing
nodes using the Administration Console. To do this, you need to perform the following
configuration steps:

1. Log-in to the Administration Console
2. Add new processing nodes
3. Install Grid Node software to processing nodes.

1.7.1 Logging into the Administration Console

Log into the Administration Console (as administrator) to manage an eCognition system.

1. If you select “set licensing later”, the local host is assigned as the default License Server. When you sub-
sequently install the License Server software on another machine, you must open the floating.lic file with a
text editor and manually change localhost to your license server IP address. The default path of floating.lic
is C:\Program Files\eCognition Client or product name, Version number\bin\lic\floating.lic. After saving and
closing, restart the Control Service to apply the changes.
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1. To open the Administration Console, go to the Windows Start menu and select All
Programs > eCognition Grid > Admin Console. Your web browser displays the log
in page of the Administration Console. Alternatively, you may start a web browser
and point it to the address http://localhost:4002

2. Log-in:
• When setting up a new eCognition system and logging in for the first time,

enter the default password admin. We recommend that you change the default
password later on.

• In other cases, log in using the user name that has been prepared by the system
administrator.

3. The Manage Hardware page displays (figure 1.7). This may take several seconds.2

Figure 1.7. The Manage Hardware page

1.7.2 Adding a New Processing Node

By default, the primary node is configured as the processing node with one CPU. The
eCognition Server is fully operational after a successful installation. The primary node
is always listed as localhost in the manage hardware page. If you want to extend your
processing capacities, you can add additional processing nodes to the eCognition Server.
Using additional processing node requires the availability of adequate eCognition Server
licenses.

1. To add a new processing node, choose Hardware > Nodes > Add New Node. The
Create New Grid Node dialog displays (figure 1.8)

2. Define the properties:
• Name: Enter the machine name or IP address of the computer you want to

define as processing node
• IP Address: Enter the IP address of the computer you indicated in the Name

field according to the following pattern: 127.0.0.1. If the Name field already
contains the IP address, you can leave this field empty

• Install: Select an installation script. By default an installer for your operating
system is available

2. You can update the Manage Hardware page by pressing the function key F5. This, however, does not apply
when the status of a processing node changes from Unavailable to Online. The new status of the node is only
displayed after clicking Unavailable in the Status column.
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• Drive: Enter the letter of the drive where the eCognition Node software is
going to be installed, for example C

• Path: Enter the installation path where the eCognition Node software is go-
ing to be installed, for example Program Files\eCognition Node Grid. Non-
existing folders are created

• Number of Engines: You can enter a number of instances of Analysis Engine
Software, if you want to run more than one on this processing node. Typically,
you run one instance per processor/core

• Temp Path: You can enter a path used for cache files. During image analysis,
the temp folder is used to store working files that may consume large amounts
of disk space

3. Click the Create Grid Node button. The new processing node is listed on the Man-
age Hardware page

Figure 1.8. Create New Grid Node dialog of the Manage Hardware page

1.7.3 Install Processing Node Software

This step will install only the Control Service and the Configuration Service. The Anal-
ysis Engine will be installed automatically by the Configuration Service when jobs are
submitted to the server. A processing node can run multiple versions and configurations
of the analysis engine. The Configuration Service automatically installs the correct ver-
sion for a job to the processing nodes. All available versions of the analysis engine are
managed by the Deployment Server.

After the installation, only the Analysis Engine of the current version is available on the
Deployment Server. You can upload additional Analysis Engine packages with different
versions using the Administration Console.

1. To install Grid Node Software to new processing nodes, choose Hardware > Nodes
> Install Nodes. The Install Grid Node Software to New Nodes page (figure 1.9)
displays a list of all new processing nodes.

2. Select the check boxes of all processing nodes you want to install.
3. Enter login information for the Installation User and the Service User:

• The Installation User is the user who provides the software installation rights
for the processing node.
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• The Service User is the user who provides the service rights for the processing
node.

4. Click the Run Installation button. The changes may take some time. After installa-
tion of all selected nodes, you will be redirected to the Manage Hardware page. All
changes are displayed in the Status column, which should be “online”. That means
the processing node is connected and ready to process jobs.
If not, check the installation log. You may want to modify the properties or the
configuration. Afterwards you can start the installed services manually.

Figure 1.9. Install Grid Node Software to New Nodes dialog of the Manage Hardware page

1.8 Load and Install Software Packages on the
Deployment Server

The eCognition Server is able to run different versions and configurations of the Analysis
Engine. This feature allows you to upgrade the eCognition Developer 8.64.0 software
by keeping full backward compatibility for existing solutions. Different versions and
configurations are managed using software packages.

You can upload and install software packages on the Deployment Server with the
Administration Console. Uploaded packages are automatically distributed to pro-
cessing nodes. Packages are stored in .dpk files. These files follow the nam-
ing convention eCognition 8.64.0 [LifeServerVersion Build Number].dpk (for example
<linkdobjc>.1.0.0.1090.dpk).

1. To load and install a new software package, choose Software > Packages > Upload
New Package. The Upload New Software Package dialog displays (figure 1.10)

2. Click the Browse button and browse to an installation folder you received from
eCognition Node. Select a .dpk file containing an eCognition Node software pack-
age
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3. Click the Upload Software button. The new package is listed on the Manage Soft-
ware page with status installed.

Figure 1.10. Upload New Software Package dialog of the Manage Software page

1.9 Image Proxy Server

The Image Proxy Server (IPS) is a Windows software component that provides high-
performance image access and caching. An IPS is Windows-based and automatically
deployed with eCognition Node clients, and must be installed in your server environment.
The Image Proxy Server provides the following functionalities:

• Delivering Windows-only file formats to eCognition Linux servers
• Creating and delivering zoom pyramids for large images
• Creating and delivering thumbnail caches for workspaces
• Creating and delivering an image statistics cache
• Creating and delivering cached zoom pyramids for thematic layers
• Creating and delivering cached raster representations of vector files

The Image Proxy Server (IPS) is a set of client-server components to address a variaty
of issues around image access. The general purpose is to introduce a unified component
to provide all services around performing image access in a centralized fashion and a
scalable deployment architecture. The following use case describes the concrete require-
ments that will be addressed by the Image Proxy Server

1.9.1 Installing the Image Proxy Server

Double-click the Setup.exe file to begin the installation. Follow the instructions onscreen
the only configurable options during installation are:

• You can change the folder in the Start menu where the program shortcut will be
placed

• You can change the installation path
• You can choose whether to install documentation and sample projects (below)
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1.9.2 Post-Installation

The image server installation creates the most common configuration of the image server,
where image cache files are stored locally and image cache creation is the responsibility
of the local machine. For a more advanced configuration, you must edit the configuration
file and restart the eCognition Image Proxy Server 8.0.

Changing Image Proxy Server Default Settings

After Installing the Image Proxy Server you may wish to change the default settings.

• Locate the eCogntion.cfg file in the bin/config folder where you installed the Image
Proxy Server.

• Create a backup of the default file
• Edit the file using a text editor such as Notepad
• Restart the eCognition Image Proxy Server 8.0
• Access the Image Proxy Service from an eCognition Node client to ensure it is

operating correctly.

The following table describes the configuration parameters for the Image Proxy Server.

Name Description Default Value

Mode Do not change this value as this is a central
IPS.

Central

Caching True = Image Proxy Server creates cache
files. Normally this would not be changed.

Cache Processing
None = No Caching
Local = Use the local processors to create
cache files (Default)
Cluster = Use the eCogntion Server to create
cache files.(Advanced)

True

Local

Caching package The version of the Image Proxy Server to be
used. Do not change this.

ImageCache.1.2.last

Central storage When false any image cache data is stored
with the associated images. If the Image
Proxy Server does not have access to the
central location then the image proxy cache
will be created in the central location.

False

Max caching
processes

The number of concurrent threads that may
be started for caching. By default set to 1 for
desktop and 4 for centralized server usage.

4

Cache buffer Memory (MB) used by caching process for
buffering.

256
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Name Description Default Value

Central storage
location

The location of the cache data. Please note
that if the Caching value is set to cluster this
should be a network share (UNC Path) that is
also accessible to all engines.

C:\ Documents and
Settings\All
Users\Application
Data\eCognition
Node\Img
ProxyServerCache

Max cache size The maximum storage size of the cache (GB) 10

Delete cache older After this number of hours the cached item
will become eligible for deletion.

720

Keep cache younger The number of minutes that items should
always be kept in the cache.

60

Preferred compression The default image compression technique.
Can also be zlib.

jpeg

Jpeg quality The quality. 100% equals lossless. Set range
30–99%.

100

Telling Clients and eCognition Servers About Your New IPS

It will be necessary to tell the rest of the software in your environment about the new
Image Proxy Server.

Client Configuration For eCognition Node clients you will need to update the Manage
Local Servers dialog box (Tools > Manage Local Servers). In the Central IPS Location
field, enter the Image Proxy Server name and port. (See also Configuring a Central Image
Proxy Server on page 13).

eCognition Server Configuration If you have decided to install a centralized Image Proxy
Server, you will need to update the configuration of all eCognition Server nodes to point
to the IPS.

In the Administration Console enter ‘true’ in the ‘use image proxy’ field and enter the
Image Proxy Server address and port number in the ‘image proxy’ field.
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Figure 1.11. Image Proxy Server settings can be edited in the Administration Console (Hard-
ware > [Select Node] > Config)
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2 Setting up Data Management
with Relational Database

Data Management enables eCognition Developer 8.64.0 clients to view, manage, and
search workspaces, rule sets and result data generated by eCognition systems.

Data Management interacts with a relational database for data management and storage.
Access to the database is required for eCognition Developer 8.64.0 clients and from the
Data Management Spooler service. The Data Management Spooler service is part of Data
Management and is responsible for spooling result data into the data store. It is installed
on the primary node of the eCognition Grid.

To set up Data Management you have to prepare your database, set up open database con-
nectivity (ODBC) drivers for the client machines and the spooler service, and configure
your storages, users, and access rights using the Administration Console.

1. Set up the Data Stores.
2. Create user accounts: Each user connecting to Data Management should have an

individual user account.
3. Define and configure user groups. User accounts can be organized into groups to

reflect the organizational structure of your department or company. Access rights
to storages and workspaces are granted at a group level.

4. Set up and configure access types for Data Management. Access types describe
typical access patterns for selected groups. Each workspace in Data Management
has one specified access type.

We recommend that the setup of Data Management is done by a database administrator
following the details contained in this section.

1. Prepare your database for the use with Data Management:
• Set up a table space to represent a Data Store.
• Set up an associated user account for each table space you want to use. This

user account will be used to identify the correct table space when you log on
to Data Management.

• It is not necessary to create the database schema explicitly; this will be done
automatically by Data Management.

2. Configure Data Management using the Administration Console:
• Set up the data stores
• Create user accounts – each user connecting to Data Management should have

an individual user account
3. Configure the Data Management Spooler service:
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Figure 2.1. Data Management components interacting with the database

• Install ODBC driver on the primary node of the eCognition Grid: The Data
Management Spooler service accesses the database using the ODBC driver.

• Edit the eCognition.cfg configuration file to configure the Data Management
Spooler service.

4. Set up clients: The correct ODBC driver needs to be installed on the client ma-
chines in order to connect to Data Management.

2.1 Prepare an SQLite Database

If you prefer not to download and configure a database, you can create a personal database
file.

In eCognition Developer 8.64.0, go to File > Connect to Data Store. The Connect to Data
Storage dialog box will open (figure 2.2). To use SQLite, select ‘Desktop DM File’ from
the drop-down box in the data storage field. Press Select/Create Database File to select a
database (.ddm) file or create a new one.

This option supports most data management features, but does not allow advanced options
such as user privileges and multi-user access. Therefore, it is probably best suited to a
standalone workstation.
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Figure 2.2. Connect to Data Storage dialog box

2.2 Prepare an Oracle Database for Data Management

Data Management organizes data into data stores. You can set up one or more data stores;
the number depends on the structure and the processes of your organization. For each
data store you need to configure a table space and a user account in your Oracle database.
Data Management requires an Oracle 10g R2 database to be installed on either Windows
or Linux.

We strongly recommend that your database runs on a separate host machine with suffi-
cient resources for efficient database access. Please refer to your Oracle documentation
for details.

2.2.1 Create a New Tablespace for an Oracle Database

Each Data Store requires a separate tablespace in the Oracle database.

2.2.2 Create a New Oracle Database User Account

Data Management identifies the correct tablespace using the database user account, when
it connects to the database. Therefore, a unique database user account is required for each
data store used by eCognition software. The Oracle database user account should have
the following configuration:

• Roles
– Connect
– Resource

• System Privileges
– Create View
– Unlimited Tablespace
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Figure 2.3. Example Oracle Tablespace Setup for a Data Store

Figure 2.4. Example Oracle User Setup for a Data Store

NOTE: Please take care to grant all of these permissions correctly. If you
fail to do so the schema may be created incorrectly. If this is the case you
will need to drop the tables and views created from the database, correct
the permissions and then connect to the store from a client to recreate the
schema.

2.2.3 Initialize the Database Schema

The database schema is created automatically by Data Management the first time you
connect to a new data store from an eCognition client. No additional steps are required
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during installation and configuration. Database schema creation is a fast process and the
user is unlikely to be aware that the schema is being initialized for use. As a database
administrator, you can modify the default settings using the corresponding administration
tools.

2.3 Prepare an IBM DB2 Database for Data Management

Data Management organizes data into data stores. You can set up one or multiple data
stores; the number depends on the structure and processes of your organization. For
each data store you need to configure a table space and a user account in your IBM DB2
database. Data Management requires an IBM DB2 database to be installed on either
Windows or Linux. We strongly recommend that your database run on a separate host
machine with sufficient resources. Please refer to your IBM DB2 documentation for
details.

2.3.1 Create a New Tablespace for an IBM DB2 Database

Each data store requires a separate tablespace in the IBM DB2 database.

Figure 2.5. Example IBM DB2 Tablespace Setup for a Data Store

2.3.2 Create a New IBM DB2 User Account

Data Management identifies the correct tablespace by the database user account when
connecting to the database. Therefore a unique database user account is required for each
data store used by eCognition software. The IBM DB2 database user account is based on
Windows users. The user must be a member of the administrators’ group:
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Figure 2.6. Example IBM DB2 User Setup for a Data Store

2.3.3 Initialize the Database Schema

The database schema is created automatically by Data Management the first time you
connect to a new data store from a Trimble client. No additional steps are required during
installation and configuration. Database schema creation is a fast process and the user
is unlikely to be aware that the schema is being initialized for use. As a database ad-
ministrator, you can modify the default settings using the corresponding administration
tools.

2.4 Prepare a MySQL Database for Data Management

Data Management organizes data into data stores; the number of data stores you will need
will depend on the structure and processes of your organization. For each data store you
must configure a schema and a user account in your MySQL database. Data Management
requires an MySQL database running on Windows or Linux. Hosting you database on
a separate machine with sufficient resources is strongly recommended – please refer to
your MySQL documentation for details.

2.4.1 Create a New Schema for a MySQL Database

Each data store requires a separate schema in the MySQL database (figure 2.7).

2.4.2 Create a New MySQL User Account

Data Management identifies the correct tablespace in the database user account when
connecting to the database; therefore a unique database user account is required for each
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Figure 2.7. Example MySQL schema setup for a Data Store

data store. In addition, the necessary privileges must be added for the newly created user
(figure 2.8).

Additionally the schema privileges has to be added for the newly created user (figure 2.9).

2.4.3 Initialize the Database Schema

Data Management creates the database schema the first time you connect to a new data
store from a Trimble client. No additional steps are required during installation and
configuration. Database schema creation is a fast process and the user is unlikely to be
aware that the schema is being initialized for use. As a database administrator, you can
use the administration tools to modify the default settings.

2.5 Log into the Administration Console

The following sections instruct you in connecting the prepared database to Data Man-
agement and explain the additional server-side and client-side configurations required to
set up Data Management. Most of these configuration steps are accomplished using the
Administration Console. Continue by logging into the Administration Console.
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Figure 2.8. Example MySQL user setup for a Data Store

Figure 2.9. Example MySQL Schema Privileges Setup for a Data Store
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2.6 Add New Storage

Each tablespace needs to be registered in the Administration Console as a data store. This
is done by adding a new storage. The information kept in the storages is used to manage
all connection information to your database in a central place.

Figure 2.10. Manage Storages page

1. To add new storages choose Storage > Storages. The Manage Storage page displays
a list of existing data stores.

2. Click Add New Storage. The Create New Storage dialog displays
3. Click the Create Storage button. The new storage is listed on the Manage Storage

page.
4. Define the database properties (see table 2.1 on the next page, Configuration of an

Oracle database, table 2.2 on the following page, Configuration of an IBM DB2
database, or table 3.3, Configuration of a MySQL Database)

Figure 2.11. Create New Storage dialog

2.7 Add New Data Management User

To connect to Data Management, each user needs to have an active user account with
appropriate user rights in the Administration Console. We recommend that you create
separate user accounts for all users who want to work with Data Management.

1. To add a new user, choose Users > Users > Add New User. The Create New User
dialog displays.
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Table 2.1. Configuration of an Oracle database

Name Enter a name for this storage. This storage name is displayed in
the user interface of Trimble clients when users select a Data
Store to connect to.

Service Enter the service name of the database of the form:
//Name of processing node/servicename Example:
//pe1955n010/orcl or //pe1955n010/xe

User Enter the user name of the Oracle user account.

Password Enter the related password.

Storage Type Oracle ODBC

Table 2.2. Configuration of an IBM DB2 database

Name Enter a name for this storage. This storage name is displayed in
the user interface of Trimble clients when users select a Data
Store to connect to.

Service Enter a string explaining the log-in details for the database of the
form: Database=Database name;Hostname=Machine name;
ServiceName=50000;Protocol=TCPIP Example:
Database=DEF_DM;Hostname=MyDB2_Host;
ServiceName=50000;Protocol=TCPIP

User Enter the user name of the Windows account that you created for
the IBM DB2 database.

Password Enter the related password.

Storage Type IBM DB2.

Table 2.3. Configuration of a MySQL Database

Name Enter a name for this storage. This storage name is displayed in
the user interface of Trimble clients when users select a Data
Store to connect to.

Service Enter a string explaining the log-in details for the database of the
form: Server=Machine Name; Database=Schema Name

Example: Server=radellq;Database=diatest

User Enter the user name of the Windows account that you created for
the MySQL database.

Password Enter the related password.

Storage Type MySQL
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2. Clear the Active checkbox if you want to activate the user status later. Generally,
you should not select the Access Right to Admin Console checkbox, because this
assigns administrator rights for the Trimble system. Administrators need not de-
fine a password now; a new administrator logs in for the first time with an empty
password and then defines a password afterwards.

3. Click the Create User button. The new user is listed on the Manage Users page.
By default, the new user is part of the All Users user group. You can add users to
defined user groups

2.8 Add New Groups

Define new groups of users. Groups enable you to categorize users according to their
roles within your processes. Access rights in Data Management are only granted to entire
groups, not individual users.

Figure 2.12. Manage Groups page

1. To create groups and assign users to groups, choose Users > Groups to display a
list of existing groups on the Manage Groups page.
The groups All Users and Administrators are available by default. Every new user
is automatically a member of the All Users group.

2. Choose Users > Groups > Add New Group. The Create New Group dialog dis-
plays.

3. Enter a name for the group and a description.
4. Click the Create Group button. The new group is listed on the Manage Groups

page.

Figure 2.13. Create New Group dialog
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2.9 Assign Users to Groups

Because access rights are generally granted at the group level, we recommend that you
assign each user to one or more groups. By default, each new user will be assigned to the
All Users group.

1. To select users for a group, choose Users > Groups. The Manage Groups page
displays the list of available groups.

2. Select a group by clicking on its name. The Select Users for Group dialog displays
a list of available users.

3. Select the checkboxes of each user you want to include as a member of this group.
Clear the checkboxes of users that will not be members of this group.

4. Click the Apply Changes button. The changes are displayed in the Users column
of the Manage Groups page. Alternatively, you can select groups for each user.

Figure 2.14. Select Users for Groups dialog

2.10 Define Group Access for Storages

Figure 2.15. Manage Storages page

You can specify the groups that are allowed to access each storage. By default, all users
have access rights to a new storage.

1. To select user groups for a storage choose Storage > Storages. The Manage Storage
page displays a list of existing data stores
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2. Select a storage by clicking on its name. The Select Groups with Access to Storage
dialog displays a list of available groups

3. Select the checkboxes of groups that will access this storage. Clear checkboxes of
groups that will not access this storage

4. Click the Apply Changes button. The changes are displayed in the Accessible for
Groups column of the Manage Storages page.

Figure 2.16. Select Groups with Access to Storage dialog

2.11 Add Access Types

An access type defines a typical access rights pattern for each group.

Figure 2.17. Manage Access Control page

1. To create access types and assign rights to users groups, choose Users > Access to
display a list of existing accss types on the Manage Access Control page

2. To add an access type, choose Users > Access > Add New Access Type. The Create
New Access Type dialog displays

3. Enter a name for the access type
4. Click the Create Access Type button. The access type is listed on the Manage

Access Control page.
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Figure 2.18. Create New Access Type dialog

2.12 Assign Groups to Access Types

For each access type, you have to define access rights for each group. The rights con-
trol the following user actions: creating, reading, updating (including modifying) and
deleting.

1. To edit access rights, choose Users > Access. The Manage Access Control page
displays the list of available access types.

2. Select an access type by clicking on its name. The Define Access Rights For dialog
displays a list of available groups

3. For each group (one per row), select the checkboxes of allowed user actions and
clear the checkboxes of user actions that will not be allowed

4. Click the Apply Changes button. The changes are displayed in the Description
column of the Manage Access Control page.

Figure 2.19. Define Access Rights dialog

2.12.1 Minimize the Complexity of Access Rights.

The way access rights can be configured for Data Management allow many different
configurations. However, we strongly recommend using only the three combinations
below:

• Read Only Access: Select the Read checkbox only.
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• Normal Access: Select the Create, Read and Update checkboxes.
• Full Access: Select all checkboxes: Create, Read, Update and Delete.

2.13 Configure Data Management Spooler on Primary
Node

The Data Management Spooler service is responsible for spooling data results from the
processing nodes into the data store and is installed on the primary node in the eCognition
Grid.

To operate the Data Management Spooler service, you need to setup an ODBC connection
and adapt the configuration files of the primary node.

2.13.1 Install the Correct ODBC Driver

Install an appropriate ODBC driver1 for your database on the primary node of the eCog-
nition Grid.

Configure the Oracle ODBC Driver

On the primary node of the eCognition Grid, set up an ODBC connection.

1. To set up ODBC choose Start > Control Panel > Administrative Tools > Data
Sources (ODBC)

2. Add a new user or system DSN (figure 2.20)
3. Select the appropriate driver (figure 2.21)
4. Configure the settings (figure 2.22)
5. Test the connection using one of the storage connection settings from the Manage

Storages page of the Administration Console. A message confirms a successful
connection (figure 2.23 on page 39, figure 2.24)

6. Confirm the DSN name displayed in the ODBC Data Source Administrator dialog
box matches the name defined in the configuration of the eCognition Grid. The
default for Oracle ODBC type is Oracle (figure 2.25)

7. Confirm connectivity by logging into a n eCognition client and connecting to the
Data Store.

2.13.2 Edit the Configuration to Start the Data Management Spooler
Service

The Data Management Spooler service must be configured to start on the primary node
of the eCognition Grid and support all registered storages.

1. To configure the Data Management Spooler service, go to the Administration Con-
sole and choose Hardware > Nodes. The Manage Hardware page displays a list of
nodes

1. If you are running the 32-bit edition on a 64-bit platform, you will need to use the 32-bit ODBC driver.
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Figure 2.20. ODBC Data Source Administrator dialog box

Figure 2.21. Select a driver in the Create New Data Source dialog box

Figure 2.22. Oracle ODBC Driver Configuration dialog box
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Figure 2.23. DSN name displayed in the Administration Console

Figure 2.24. Oracle ODBC Driver Connect dialog box

2. Click the Edit button of the primary node (localhost). The Properties of Node
Localhost dialog displays.

3. Choose Config to open the Configuration of Grid Node dialog
4. In the DIAGRID section, go to the Start data spooler entry. For each storage that

you want to use, you have to start a separate Data Management Spooler Service.
Enter all names of storages to be started separated by commas.
Example: development,qa,production

5. Optional Configuration: Specify a different user or password the Data Management
Spooler service uses to connect to Data Management. By default it uses the built-in
administrator account and password:

• In the DIASpooler section of the configuration, go to the user name entry.
Enter the new user name. Enter the related password in the corresponding
entry

6. Restart the Control Service to make sure the changes are updated.

Figure 2.25. DSN name displayed in the ODBC Data Source Administrator dialog box
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2.14 Prepare Client Machines

The Oracle ODBC driver needs to be installed on every Trimble client machine that you
want to be prepared to use Data Management.

The following Trimble clients can access Data Management:

• eCognition Developer 8.64.0
• eCognition Architect 8.64.0

2.14.1 Install ODBC Driver on Client Machines

The installation procedure on machines that provide a Trimble client is the same like on
the primary node of the eCognition Grid.

2.14.2 Test Data Management Connection

Start the Trimble client and try to connect to the data store.

Figure 2.26. Connect to Data Storage dialog box with example connection

1. To connect to a Data Store go to File > Connect to Data Store in the main menu bar
to open the Connect to Data Storage dialog box (figure 2.26).

2. Enter the required information to connect:
• Authentication Server
• User Name
• Password

If you are not sure about these entries, ask the administrator of your Trimble
system.

3. Click the Choose Data Storage button to select a Data Store
If you do not have the required information, you will need to obtain it from the
system administrator.

4. Select the Save Settings checkbox to preserve your entries. Click OK to connect.
• When you are connected, the Query View displays automatically.
• You can also open the Query View in any of several window layouts.
• While you are connected, a message displays in the Status Bar at the bot-

tom of the main window, indicating that you are connected and the title bar
displays the name of the Data Store.
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• In addition, the Disconnect from Data Storage option in the File menu be-
comes available.

5. When you want to disconnect and/or connect to a different Data Store, select File
> Disconnect from Data Store in the main menu bar.
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3 Administer an eCognition®

System

Many functions for managing an eCognition system are available via a web browser,
using the Administration Console to maintain software, hardware, users, and storage.
You can also monitor processing activities.

3.1 Log into the Administration Console

You will need to log on to the Administration Console as an administrator to manage an
eCognition system.

1. To open the Administration Console, go to the Windows Start menu and navigate
to Start > All Programs > eCognition Grid > Admin Console. Your web browser
displays the log in page of the Administration Console. Alternatively, you may
start a web browser and point it to the address http://localhost:4002

2. Log in:
• When setting up a new eCognition system and logging in for the first time,

enter the default password admin. We recommend that you change the default
password later on.

• In other cases, log in using the username set up by the system administrator.
3. The Manage Hardware page displays (this may take a few seconds to load)

3.2 Manage eCognition Server Hardware

Use the Administration Console for installation and management of processing nodes of
the eCognition Server.

1. Log into the Administration Console
2. Choose Hardware > Nodes. The Manage Hardware page displays a list of existing

processing nodes
3. You may wish to proceed to one of the following sections:

• Manage Processing Nodes on the following page
• Manage Installation Scripts on page 50
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Figure 3.1. The Manage Hardware page

3.2.1 Manage Processing Node

Select Hardware > Nodes to display a list of existing processing nodes. By default, the
primary node hosts a configured processing unit that is listed as a node. Processing nodes
can display a number of states:

• New: A new processing node before the installation of Grid Node software.
• Starting Services: The Administration Console starts the installed services. That

means the processing node prepares its processing ability and gets activated. This
status will change to online. If activation is not possible the status will switch to
unavailable after 60 seconds.

• Service Stopped: The Administration Console stops the running services. That
means the processing node terminates its processing ability.

• Online: The processing node is active. That means the processing node is con-
nected and ready to process jobs. The installed services cannot be stopped until
currently processing jobs are completed.

• Offline: The processing node is inactive. That means the processing node is dis-
connected and thus not ready to process jobs. However, services are still running.

• Unavailable: The processing node is not available. You may check the network
connection and the activity of the Configuration Service. If this does not help,
check the installation log.

• Already in Use: The processing node is not available because the installed services
are blocked, for example by another eCognition Grid.

Add New Processing Node

To enable distributed image analysis processing, define and add new processing nodes to
the eCognition Server. By default, the primary node already hosts a configured process-
ing unit that is listed as a node called localhost. After a minimal setup of an eCognition
system, it can be used for a minimal processing environment without adding new process-
ing nodes.

If you want to extend your processing capacities you can configure additional processing
nodes, which compute the distributed high-throughput image analysis. That way you
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prepare your eCognition system for distributed processing on multiple machines within
an eCognition Grid. Distributed processing requires the availability of adequate licenses.

1. To add a new processing node, choose Hardware > Nodes > Add New Node. The
Create New Grid Node dialog displays.

2. Define the properties:
• Name: Enter the machine name or IP address of the computer you want to

define as processing node.
• IP Address: Enter the IP address of the computer you indicated in the Name

field according to the pattern 127.0.0.1. If the Name field already contains
the IP address, you can leave this field empty.

• Install: Select an installation script. By default an installer for your operating
system is available.

• Drive: Enter the letter of the drive where the eCognition Node software is
going to be installed (for example the C:\ drive)

• Path: Enter the installation path where the eCognition Node software is going
to be installed, for example Program Files\eCognition Grid. Non-existing
folders are created.

• Number of Engines: You can enter a number of instances of Analysis Engine
Software, if you want to run more than one instance on this processing node.
Typically, you run one instance per processor/core.

• Temp Path: You can enter a path used for cache files. During image analysis,
the temp folder is used to store working files that may consume large amounts
of disk space.

3. Click the Create Grid Node button. The new processing node is listed on the Man-
age Hardware page.

Edit Properties of a Processing Node

Display and edit the properties of a processing node.

1. To display, choose Hardware > Nodes. The Manage Hardware page displays a list
of processing nodes.

2. Click the Edit button of a processing node. The Properties of Node dialog displays.
3. You can edit the same properties as when adding processing nodes.

Alternatively, these and other properties can be modified using the Configuration
dialog. To access, click Config. However, we recommend using the Properties of
Node dialog for changing the above properties.

4. Click the Save Changes button to return to the Manage Hardware page.

Install Grid Node Software to New Processing Nodes

Install the Grid Node Software to new processing nodes only the Control Service and
the Configuration Service are installed. The complete eCognition Node software still
requires the Analysis Engine Software.

By minimal installation, this Analysis Engine Software is available in one version on the
Deployment Server. However, it can be provided in different versions. The Deployment
Server automatically deploys and installs it in the correct version to the processing nodes.
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Figure 3.2. Properties dialog of the Manage Hardware page.

This happens in the moment the Analysis Engine Software in a specific version is re-
quested for the first time by the Configuration Service of a processing node (which must
be defined before installation).

Figure 3.3. Install Grid Node Software to New Nodes dialog of the Manage Hardware page

1. To install Grid Node Software to new processing nodes choose Hardware > Nodes
> Install Nodes. The Install Grid Node Software to New Nodes dialog displays a
list of uninstalled processing nodes.

2. Select the checkboxes of processing nodes you want to install.
3. Enter the login information for the installation user and service user:

• The installation user is the user who provides the software installation rights
for the processing node

• The service user is the user who provides the service rights for the processing
node.
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4. Click the Run Installation button. The changes may take some time. After instal-
lation of all selected nodes, you will be redirected to the Manage Hardware page.
All changes are displayed in its Status column (the status should be Online). That
means the processing node is connected and ready to process jobs. If not, check
the installation log. You may want to modify the properties or the configuration.
Afterwards you can start the installed services manually.

Display Installation Log In case of installation problems, display the installation log.

1. To display the installation log choose Hardware > Nodes. The Manage Hardware
page displays a list of processing nodes.

2. Select a processing node by clicking on its name. The Installation Log For dialog
displays all available installation logs.

3. To delete the installation log choose the Clear button. After confirmation the avail-
able installation logs are deleted.

Review and Edit Configuration of a Node

Display and edit the configuration of the primary or a processing node. You can edit
a configuration if you want to change settings like the number of instances of Analysis
Engine software or to the path of the temp folder.

1. To display a configuration, choose Hardware > Nodes. The Manage Hardware page
displays a list of nodes.

2. Do one of the following:
• Click the Edit button of a node. The Properties of Node dialog displays.
• Select a node by clicking on its name. The Installation Log For dialog opens.

3. Choose Config to open the Configuration of Grid Node dialog.
4. If needed, edit the configuration parameters in the form.
5. Click the Apply Changes button. The configuration is saved as eCognition.cfg file

in the installation of each node.
6. Stop and restart the Control Service of the related nodes to make sure the changes

are updated.

Restarting the Control Service on the Primary Node Restarting the Control Service on
the primary node of the eCognition Grid terminates all jobs currently processed by this
eCognition Grid. This includes currently processing jobs and those that are pending in
the job queue.

The Control Service on the primary node is responsible for starting all other components
of the eCognition Grid architecture. That means that all components on the primary
node will be stopped and restarted. Consequently all jobs will be lost and will need to
be resubmitted. Therefore, we strongly recommend that you schedule the restart of the
Control Service at a time when no jobs are processed.

Stop the Control Service

Stopping the services on a processing node will terminate its activity.
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Figure 3.4. Configuration of Grid Node dialog of the Manage Hardware page

When the configuration of a node is changed, the Control Service must be restarted to
enable this change. In addition, you must to stop the Control Service before uninstalling
a processing node. Any jobs that are currently being processed must be deactivated before
the services of a processing node are terminated. To stop a service:

1. Go to Hardware > Nodes > Stop Service. The Stop Control Service for Grid Nodes
dialog displays a list of processing nodes with active services. Any nodes that you
wish to stop must be deactivated beforehand

2. Select the checkboxes of processing nodes whose services you want to stop
3. Click the Stop Service button. The changes are displayed in the status column of

the Manage Hardware page. The status should be “service stopped”.

Start the Control Service

Start the Control Service in one of the following situations:

• If the state of a processing node is “unavailable”
After the installation of Grid Node software, the status of all processing nodes
should be online by default. That means the services should be started and the
processing node should be connected and ready to process jobs. If the status is
unavailable, you can change the configuration and try to restart the services.

• After changing the configuration of a node you must stop and restart the Control
Service of the related nodes.

– To start the services, go to Hardware > Nodes > Start Service. The Start
Control Service for Grid Nodes dialog displays a list of processing nodes
whose services are not active. Nodes must be stopped before they are restarted

– Select the checkboxes of processing nodes you want to start the services.
– Click the Start Service button. The changes are displayed in the Status col-

umn of the Manage Hardware page. The status should change to “starting
services” then “online”. That means the processing node is connected and
ready to process jobs. If activation is not possible, the state will switch to
“unavailable” after 60 seconds.
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Deactivate Processing Nodes

Deactivate a processing node to disconnect it. This is required before you stop the ser-
vices of a processing node to ensure completion of a currently processing job.

1. To deactivate a processing node, choose Hardware > Nodes > Deactivate. The
Deactivate Grid Nodes dialog displays a list of active processing nodes.

2. Select the checkboxes of processing nodes you want to deactivate.
3. Click the Deactivate button. The changes are displayed in the status column of

the Manage Hardware page. The status should be “offline” the processing node is
disconnected and not ready to process jobs. However, services are still running.

Activate Processing Nodes

After installation of Grid Node software, the status of the processing node should be
online. That means the services should be started and the processing node should be
connected and ready to process jobs. If the status is not online, you can change the
configuration and try to reactivate the processing node:

(Restarting the control service of a processing node will also activate it; a separate activa-
tion, as described below, is unnecessary.)

1. To activate a processing node, choose Hardware > Nodes > Activate. The Acti-
vate Grid Nodes dialog displays a list of inactive processing nodes with running
services.

2. Select the checkboxes of the processing nodes you want to activate.
3. Click the Activate button. The changes are displayed in the status column of the

Manage Hardware page. The status should be online, meaning that the processing
node is connected and ready to process jobs.

Uninstall eCognition Node software from Processing Node

To uninstall software from a processing node, the processing node must first be deacti-
vated, then the service stopped. Then perform the following steps:

1. To uninstall, choose Hardware > Uninstall Nodes. The Manage Hardware page
displays the list of processing nodes.

2. Click the Delete button of a processing node.
3. Reconfirming will update the Manage Hardware page. The affected processing

nodes display the status “new”.

Delete Processing Node

To delete unwanted processing nodes from an eCognition Grid:

1. Go to Hardware > Nodes. The Manage Hardware page displays a list of processing
nodes.
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2. Click the Delete button of a processing node1

3. Reconfirm and the list on the Manage Hardware page is updated.

3.2.2 Manage Installation Scripts

Figure 3.5. Manage Installation Scripts page

Installation scripts are used as installers of processing nodes within an eCognition Grid.
Select Hardware > Installers to display a list of existing installers on the Manage Installa-
tion Scripts page.

By default, an installer for the current standard operating system is listed.

Add a New Installer

To create a new installer, load an installation script from file:

1. To create a new installer, choose Hardware > Installers > Add New Installer. The
Create New Installer dialog displays.

2. Click the Browse button and select a script file.
3. Enter a name to overwrite auto naming.
4. Click the Create Installer button. The new installer is listed on the Manage Instal-

lations Scripts page.

Edit Installation Script

To modify an installer by editing the installation script or loading a script file:

1. To modify an installer, choose Hardware > Installers. The Manage Installation
Scripts page displays a list of available installers.

2. Select an installer by clicking on its name. The Properties Of dialog displays.
3. You can edit the name and script or load a script file.
4. Alternatively, click Download to save the installation script (the script can then be

edited using a text editor.
5. Click the Apply Changes button. The time of change is displayed in the Updated

At column on the Manage Installation Scripts page.

1. It is not possible to delete the localhost processing node, as it is part of the default minimal processing environ-
ment.
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Delete Installation Script

To delete an unwanted installer:

1. Go to Hardware > Installers to list available installers
2. Click the Delete button of the installer
3. Reconfirm and the list on the Manage Installation Scripts page is updated.

3.3 Prepare Different Software Packages for Deployment

Use the Administration Console to manage Analysis Engine software, which is contained
in software packages. Software packages are managed by the Deployment Server to
prepare them for deployment to the processing nodes of the eCognition Grid.

A software package contains a version of the Analysis Engine Software. A version can
be either a version released by eCognition or a version customized using the Software
Development Kit (SDK).

By default, the primary node hosts a preconfigured processing unit that is included in the
automatic deployment of software packages. In some cases you may want to use other
software packages, for example:

• An eCognition Developer software package to support analysis of multidimen-
sional image data

• Older versions of software packages are required for processing old rule sets
• Bug fixes of the Analysis Engine software
• Customized software packages.

To enable the automatic distribution of the contained Analysis Engine software to process-
ing nodes of the eCognition Grid, you need to load and install them on the Deployment
Server.

1. Log-in to the eCognition Administration Console
2. Choose Software > Packages > List Packages. The Manage Software page displays

a list of existing software packages.

Figure 3.6. Manage Software page
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3.3.1 Load and Install Software Packages on the Deployment Server

Load and install software packages on the Deployment Server to enable the automatic dis-
tribution of the contained Analysis Engine software to processing nodes of the eCognition
Grid. This requires a ServerVersion and build number.dpk file, containing a n eCognition
software package (for example, XDLifeServer.1.0.0.1083.dpk).

1. To load and install a new software package, choose Software > Packages > Upload
New Package. The Upload New Software Package dialog displays

2. Click the Browse button and browse to the installation folder you received from
Trimble. Select a .dpk file containing an eCognition software package

3. Click the Upload Software button. The new package is listed on the Manage Soft-
ware page with status “installed”.

Figure 3.7. Upload New Software Package dialog of the Manage Software page

Loading Only

Follow the first steps described in Load and Install Software Packages on the Deployment
Server above. Clicking the Upload Software button should return the status ‘available’.

If you want to install the new software package later, you can clear the Install Package
checkbox.

Installing Only

Install loaded software packages on the Deployment Server to prepare the software in-
cluded for deployment. At least one software package must be loaded on the Deployment
Server.

1. To install software packages on the Deployment Server choose Software > Pack-
ages > Install Packages. The Install Packages dialog displays a list of loaded but
not installed packages

2. Select the checkboxes of packages you want to install
3. Click the Run Installation button. The Installation date is displayed in the status

column on the Manage Software page.
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Figure 3.8. Install Packages dialog of the Manage Software page

3.3.2 Uninstall Software Packages

Uninstalling software packages from the Deployment Server stops deployment of soft-
ware but does not delete software packages; they can be installed again without being
reloading

1. To uninstall software packages from the Deployment Server choose Software >
Packages > Uninstall Package. The Uninstall Packages dialog displays a list of
installed packages

2. Select the checkboxes of the packages you want to uninstall
3. Click the Uninstall Selected Packages button. The changes are displayed in the

status column of the Manage Software page. The uninstalled packages are listed as
New. This is because they again are ready for installation as if they just had been
loaded.

3.3.3 Delete Software Packages

Delete software packages from the Deployment Server to disable further installation.
However, if you want to use a deleted software package again, you can reload and install
it as usual. At least one software package is loaded, but not installed on the Deployment
Server.

1. To delete software packages from the Deployment Server choose Software > Pack-
ages > Delete Packages. The Delete Packages dialog displays a list of loaded but
uninstalled packages

2. Select the checkboxes of packages you want to delete
3. Click the Remove Selected Packages button. The changes are displayed on the

Manage Software page.

3.4 Manage Users of Data Management and
Administrators

The Administration Console manages the user authentication for an eCognition system.
This includes user rights management for the eCognition system administration and the
use of the Data Management extension.
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A user only can work with Data Management after he or she has been defined as a user
by a system administrator. Users are managed in groups. Each group has defined access
rights.

1. Log into the Administration Console.
2. Choose Users > Users. The Manage Users page displays a list of existing users.
3. Select any the of the following tasks:

• Edit User
• Manage Users in Groups
• Manage Groups Rights in Access Types

Figure 3.9. Manage Users page

3.4.1 Edit User

To assign personal user rights to users you can add and edit users. Choose Users > Users
to display a list of existing users on the Manage Users page.

Add New Data Management User

To connect to Data Management, each user needs to have an active user account with
appropriate user rights in the Administration Console. We recommend that you create
separate user accounts for all users who want to work with Data Management.

Figure 3.10. Create New User dialog

1. To add a new user, choose Users > Users > Add New User. The Create New User
dialog displays.
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2. Clear the Active checkbox if you want to activate the user status later. In most
cases, you should not select the Access Right to Admin Console checkbox because
it assigns administrator rights for the eCognition system. Administrators do not
need to define a password at this stage; new administrators log in for the first time
with an empty password and then specify a password afterwards.

3. Click the Create User button. The new user is listed on the Manage Users page.
By default, the new user is part of the All Users user group. You can add users to
defined user groups.

Add New Administrator

To add new users as administrators of the n eCognition system.

1. Go to Users > Users > Add New User. The Create New User dialog displays.
2. Fill in the form. You do not need to define a password at this stage (new adminis-

trators can log in for the first time with an empty password and define a password
afterwards)
Select the Administrator checkbox to assign administrator rights for the system.
Select the Active checkbox if you additionally want to activate the user status for
Data Management.

3. Click the Create User button. The new user is listed on the Manage Users page.

Administrator Rights Assigning administrator rights to users means they are able to log
into the Administration Console and create new or change existing user rights. Adminis-
trators are also allowed to modify the access rights for eCognition workspaces managed
in Data Management. Administrator rights should be reserved to a limited number of
users.

Edit User Properties and Passwords

Modify user properties including password, activation status, and administrator rights.

1. To edit user properties, choose Users > Users. The Manage Users page displays
the list of users.

2. Click the Edit button for a user. The User Properties Of dialog displays.
3. Edit the properties.
4. If you want to change the password, choose Change Password. Enter the new

password in both text boxes. Click the Apply Changes button to return to the User
Properties Of dialog.

5. Click the Apply Changes button. The property changes are displayed on the Man-
age Users page.

Select User Groups for a User

To provide a user with appropriate user rights, you have to select one or multiple user
groups for the user.

1. To select user groups for a user choose Users > Users. The Manage Users page
displays the list of users.
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2. Select a user by clicking on its name. The Select Groups for User dialog displays
a list of available groups.

3. Select check boxes of groups to include the user as a member. Clear check boxes
of groups to exclude the user.

4. Click the Apply Changes button. The changes are displayed in the Groups column
of the Manage Users page.

Alternatively you can select users for each group.

3.4.2 Manage Users in Groups

A user group assembles different users depending on the user rights you want to assign to
each group. Groups enable you to categorize users, for example, according to their roles
within your processes.

After providing each group with adequate user rights each user of a group has similar user
rights. This allows easy management of access rights for the complete group of users.

To create groups and assign users to groups choose Users > Groups to display a list of
existing groups on the Manage Groups page.

Figure 3.11. Manage Groups page

The groups All Users and Administrators are available by default. Every new user is
automatically member of the All Users group.

This helps you when setting up a new eCognition system; you automatically assign basic
user rights without creating groups. All detailed definitions of users, groups and user
rights can be done later.

Add New Groups

Define new groups of users. Groups enable you to categorize users according to their
roles within your processes. Access rights in Data Management are only granted to entire
groups, not to individual users.

1. To create groups and assign users to groups choose Users > Groups to display a list
of existing groups on the Manage Groups page.
The groups All Users and Administrators are available by default. Every new user
is automatically a member of the All Users group

2. Choose Users > Groups > Add New Group. The Create New Group dialog displays
3. Enter a name for the group and a description
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4. Click the Create Group button. The new group is listed on the Manage Groups
page.

Figure 3.12. Create New Group dialog

Edit Group Properties To modify group properties:

1. To edit group properties, choose Users > Groups. The Manage Groups page dis-
plays the list of groups

2. Click the Edit button of a group. The Group Properties dialog displays
3. Edit the name or description
4. Click the Apply Changes button. The changes are displayed on the Manage Groups

page.

Assign Users to Groups

Because access rights are generally granted on the group level, we recommend that you
assign each user to one or more groups. By default, each new user will be assigned to the
All Users group.

Figure 3.13. Select Users for Groups dialog

1. To select users for a group, choose Users > Groups. The Manage Groups page
displays the list of available groups
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2. Select a group by clicking on its name. The Select Users for Group dialog displays
a list of available users

3. Select the checkboxes of each user you want to include as a member of this group.
Clear the checkboxes of users who will not be members of this group

4. Click the Apply Changes button. The changes are displayed in the Users column
of the Manage Groups page. Alternatively, you can select groups for each user.

Delete Group

Delete a group that you do not need any more.

1. To delete a group, choose Users > Groups. The Manage Groups page displays the
list of groups.

2. Click the Delete button of a group.
3. Reconfirm and the list on the Manage Groups page is updated.

3.4.3 Manage Group Rights and Access Types

An access type defines the user rights for each group. If you use multiple databases, you
may want define an access type for each database or for each type of database. This
simplifies management of user rights for all databases that have the same access type.

To create access types and assign rights to users groups, choose Users > Access to display
a list of existing access types on the Manage Access Control page.

Add Access Types

An access type defines a typical access rights pattern for each group.

Figure 3.14. Manage Access Control page

1. To create access types and assign rights to user groups, choose Users > Access to
display a list of existing access types on the Manage Access Control page

2. To add an access type, choose Users > Access > Add New Access Type. The Create
New Access Type dialog displays.

3. Enter a name for the access type.
4. Click the Create Access Type button. The access type is listed on the Manage

Access Control page.
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Figure 3.15. Create New Access Type dialog

Edit Access Type Properties Modify properties of an access type.

1. To edit properties of an access type, choose Users > Access. The Manage Access
Control page displays the list of available access types

2. Click the Edit button of an access type. The Properties of Access Type displays
3. Edit the name
4. Click the Apply Changes button. The changes are displayed Manage Access Con-

trol page.

Assign Groups to Access Types

For each access type, you have to define access rights for each group. The rights control
creating, reading, updating (modifying) and deleting.

Figure 3.16. Define Access Rights dialog

1. To edit access rights, choose Users > Access. The Manage Access Control page
displays the list of available access types.

2. Select an access type by clicking on its name. The Define Access Rights For dialog
displays a list of available groups.

3. For each group (one per row), select the appropriate permissions
4. Click the Apply Changes button. The changes are displayed in the Description

column of the Manage Access Control page.
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Simplifying Access Rights The way access rights can be configured for Data Manage-
ment allows many different configurations. However, we strongly recommend using only
the following three combinations:

• Read Only Access: Select the Read check box only.
• Normal Access: Select the Create, Read and Update check boxes.
• Full Access: Select all check boxes: Create, Read, Update and Delete.

3.5 Manage Storage of Data Management

Use the Administration Console to manage the access to data storages of Data Manage-
ment. This is only required if you use the Data Management extension.

1. Log into the Administration Console.
2. Choose Storage > Storages. The Manage Storages page displays a list of existing

data stores.

3.5.1 Add New Storage

Figure 3.17. Manage Storages page

Each tablespace needs to be registered in the Administration Console as a data store. This
is done by adding a new storage. The information kept in the storages is used to centrally
manage all connection information to databases.

1. To add new storages choose Storage > Storages. The Manage Storage page (fig-
ure 3.17) displays a list of existing data stores.

2. Click Add New Storage. The Create New Storage dialog displays (figure 3.18)
3. Define the database properties (see table 3.1 on the next page, Configuration of

an Oracle database, table 3.2 on the facing page, Configuration of an IBM DB2
database, or table 3.3, Configuration of a MySQL Database)

4. Click the Create Storage button. The new storage is listed on the Manage Storages
page.

3.5.2 Edit Storage Properties

Modify properties of a storage.
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Figure 3.18. Create New Storage dialog

Table 3.1. Configuration of an Oracle database

Name Enter a name for this storage. This storage name is displayed in
the user interface of eCognition clients when users select a Data
Store to connect to.

Service Enter the service name of the database of the form:
//Name of processing node/servicename Example:
//pe1955n010/orcl or //pe1955n010/xe

User Enter the user name of the Oracle user account.

Password Enter the related password.

Storage Type Oracle ODBC

Table 3.2. Configuration of an IBM DB2 database

Name Enter a name for this storage. This storage name is displayed in
the user interface of eCognition clients when users select aData
Store to connect to.

Service Enter a string explaining the log-in details for the database of the
form: Database=Database name;Hostname=Machine name;
ServiceName=50000;Protocol=TCPIP Example:
Database=DEF_DM;Hostname=MyDB2_Host;
ServiceName=50000;Protocol=TCPIP

User Enter the user name of the Windows account that you created for
the IBM DB2 database.

Password Enter the related password.

Storage Type IBM DB2.
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Table 3.3. Configuration of a MySQL Database

Name Enter a name for this storage. This storage name is displayed in
the user interface of eCognition clients when users select a Data
Store to connect to.

Service Enter a string explaining the log-in details for the database of the
form: Server=Machine Name; Database=Schema Name

Example: Server=radellq;Database=diatest

User Enter the user name of the Windows account that you created for
the MySQL database.

Password Enter the related password.

Storage Type MySQL

1. To edit properties of a storage, choose Storage > Storages. The Manage Storages
page displays a list of existing data stores

2. Click the Edit button of a storage. The Storage Properties dialog displays
3. Edit the properties
4. Click the Apply Changes button. The changes are displayed on the Manage Stor-

ages page.

3.5.3 Define Group Access for Storages

You can specify the groups that are allowed to access each storage. By default, all users
have access rights to a new storage.

Figure 3.19. Manage Storages page

1. To select user groups for a storage, choose Storage > Storages. The Manage Stor-
age page displays a list of existing data stores.

2. Select a storage by clicking on its name. The Select Groups with Access to Storage
dialog displays a list of available groups.

3. Select the checkboxes of groups that will access this storage. Clear the checkboxes
of groups that will not access this storage.

4. Click the Apply Changes button. The changes are displayed in the Accessible for
Groups column of the Manage Storages page.
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Figure 3.20. Create New Storage dialog

3.5.4 Delete Storage

Delete a storage that you do not need any more.

1. To delete a storage, choose Storage > Storages. The Manage Storages page displays
a list of existing data stores.

2. Click the Delete button of a storage.
3. Reconfirm and the list on the Manage Storages page is updated.

3.6 Monitoring Processing in a Web Browser

If you use eCognition Server for processing, you can control the status of jobs submitted
for processing via a web browser.

1. To display the Job Scheduler status page in your web browser, go to the machine
that host the eCognition Grid and choose the Windows Start menu > Start > All
Programs > eCognition Grid > Job Scheduler Status Page.
Alternatively, you can enter a web address that is identical to the entry in the Job
Scheduler entry of the Start Analysis Job dialog. If a local Job Scheduler is used,
you can enter http://localhost:8184

2. The HTML page is split into four parts, where you can resize the panes by clicking
on the dividers and dragging them:

• User Jobs lists all jobs on schedule.
• Job Number Overview lists all projects of a selected user job
• Engines lists the Analysis Engine software instances of participating process-

ing nodes.
Engine Usage displays the capacity utilization of all Analysis Engine Soft-
ware instances of participating processing nodes of the eCognition Grid.

3.6.1 Review User Jobs

Look in the User Jobs pane to see all jobs on the scheduler. There are four options you
can use to filter this list; any filter in use is surrounded by asterisks:
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• All is the default.
• Active Jobs are those currently being processed.
• Inactive Jobs lists successfully completed jobs and those that failed or were can-

celled.
• Failed lists only those that did not successfully finish.

Look at some of the available data in this pane:

1. Gray text means that the job has been closed because the workspace has been up-
dated and the job will soon be deleted from the database. For more information see
Reopen a Job on the next page

2. Click Active, to display only jobs currently running.
3. Push the Refresh button to reload the site.
4. Click Log to see additional information about how the job was processed. The

log lists the dates of events, followed by machine and Analysis Engine Software
number and the type of event, which are either connecting or shutting down of an
instance of Analysis Engine Software.

5. Click on the index number of a job in the User Jobs pane to view its details in the
Job Number Overview pane.

3.6.2 Review Job Overview

In the User Jobs pane, click on the job number in front of a job to switch to the Job
Number Overview pane and review processing details. Click “1” to view the processing
status of each project sent for processing, which is one of the following:

• Failed
• Waiting
• Canceled
• Processing-done
• Unauthorized
• Timeout
• Crashed

If you wish to stop the current job displayed, click Cancel in the upper-right corner.

3.6.3 View Job Details

In the Job Number Overview pane, you can review processed jobs by monitoring the
status of each project sent for processing. You can click on the item number of a project
to switch to the Job Details pane.

If processing failed, look in the Remarks section for further information. Other informa-
tion displayed includes the start and end times, the local path of the utilized rule set, a
list of the image layers submitted for processing and the path of all the output files you
specified in the Configure Exported Results dialog box, and the used configuration of the
Analysis Engine Software.
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Figure 3.21. Job Details section of the Job Scheduler page displayed in a web browser

3.6.4 Show Log

Click the Show Log link at the bottom of this page to display configuration information
for the current job.

3.6.5 Monitor Analysis Engine Software Status

In the Engines pane, the participating Analysis Engine Software instances of participating
processing nodes are listed. Filter them by selecting either only the “active” or “inactive”
instances. The status of an active instance is idle. The status of instances whose analysis
could not be completed is set to timeout. Click on the item number to display details. If
an error occurred during processing, check the Remarks pane.

3.6.6 Review Analysis Engine Software Usage

The Engine Usage pane displays two graphs representing capacity utilization of all Anal-
ysis Engine Software instances of participating processing nodes of the eCognition Grid.
The left-hand graph represents the workload of the last 60 seconds while the right one
displays data for the last 24 hours.

3.6.7 Reopen a Job

If the text for a job in the User Jobs pane is gray, the processing states and result references
have been updated in the workspace. Processing states and the result references will
eventually be deleted. The default time before deletion is five days (this value can be
changed in the Administration Console).

If you close a workspace before processing is complete, the relevant entry will not turn
gray until the workspace is reopened and updated. Once a workspace has been updated,
and the line is therefore gray, the job will be deleted from the database.
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1. If you need to reopen a job, double-click the job number to open the job in the Job
Number Overview pane.

2. Click Reopen to reopen the job.
3. The line in the User Jobs pane will turn black again.

3.7 Back Up the Administration Console Database

We highly recommend that you regularly back up the database of Administration Console.
It is stored as xdadmin.db file on the primary node of the eCognition Grid. The default
path is C:\Documents and Settings\All Users\Application Data\AdminConsoleData\db.

3.7.1 General

• Temp path is used for eCognition cache files. During image analysis, the temp
folder is used to store working files that may consume large amounts of disk space.
Examples are:

– d:\temp
– /tmp

Ensure the user who runs the Analysis Engine Software has access rights to
this temp folder.

• License Check Timeout: In case the license is not available at application startup,
the license check is retried for twice. Set the time in seconds before the license will
be requested again.

• Default Server Configuration: If you work with the DIA Command Line Client,
you can set the used software configuration needed to process the job. This in-
formation is analyzed by the eCognition Grid in order to start and configure the
Analysis Engine Software according to the requirements of the job. For regular
processing, you find these settings on the Configuration tab of the Start Analysis
Job dialog box. Examples are:

– eCognition
– eCognitionEarthServer.7.last

• Enable File Mapping: In cases of low system memory conditions you can activate
file mapping to use memory-mapped files for allocating huge processing memory
blocks. The default value is false.

3.7.2 Logging

• Log Path: Path of log files, for example .\Logs
• Max. File Size: Integer value specifying the maximum size in bytes for the log

file. The default value is 10485760. After a file size is reached, the file is deleted
and recreated. A zero value means no size limit; bear in mind that this can result
in extremely large files.

• Trace Level: Level of detail in log files. Select 1 to increases the level of detail.
Available values are 0 and 1
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3.7.3 File Management

• Samba shares prefix, for example /mnt.
Samba sharesare are assumed to have computer name denoted in lower case. For
example, for Abcd1 the samba share should look like /mnt/abcd1 not /mnt/Abcd2.

3.7.4 Storage

• The URL of the authentication server. Should be the same the Administration
Console listens to. For example:

– http://localhost:4002
– http://T41pn015:4002

3.7.5 ODBC

• Oracle DSN: ODBC data source name used for connecting to any storage of type
Oracle ODBC, for example “My Oracle”

3.7.6 ArcSDE Settings

• Connection File Location: The value of a variable defining the path of the folder
containing files with ArcSDE Connections, for example .\Connections

3.7.7 CSV Settings

• Decimal separator: A separator of decimal numbers used for export as comma-
separated value files, such as a period (.)

• Column delimiter: A delimiter used for export as comma-separated value files,
such as a semicolon (;)

3.7.8 DIAGRID

• Numbers of Engines: The number of instances of Analysis Engine software avail-
able for processing on this processing node. To change the number of engines, we
recommend using the Properties of Node, which avoids having to restart the Con-
trol Service afterwards. Use −1 to start as many threads as the number of CPUs
installed on the machine. This is also true for hyper-threading CPUs. Example
values are 1, 4 and −1.
A hyper-threading CPU is not a regular CPU. If one thread is started on the regular
CPU and another is started on the hyper-threading CPU, the hyper-threading CPU
is significantly slower than the regular CPU. However, you need a license for each
thread.

• Job Scheduler: The port the Job Scheduler monitors. Examples are
http://localhost:8148 and http://T41pn015:8148. Take care when chang-
ing the port. Do not change this value if there is no special need.

• Config Service: Port of the Configuration Services of all nodes of the eCognition
Grid. It is used for communication among Configuration Service and other com-
ponents. Examples are http://localhost:8148 and http://T41pn015:8148.
Again, do not change this value if there is no special need.
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• Use Config Service: The Configuration Service enables you to work with different
software configurations. You can disable (false) the Configuration Service to only
use Analysis Engine software and Job Scheduler for processing data. Values are
true and false

• Start Image Cache Manager: Selected image drivers require the activation of the
Image Cache Manager. Values: true or false (default)

• Start Data Spooler: For each storage that you want to use, you must start a sepa-
rate Data Management Spooler Service. Enter all names of storages to be started
separated by commas, for example development,qa,production

3.7.9 DIA Control Service

Configuration parameters for the Control Service:

• Install directory: Path to the Job Scheduler and the Analysis Engine Software
executable files. Do not change this path if there is no special need.

• Restart time: Time in seconds at which the Control Service restarts a crashed
instance of Analysis Engine Software or Job Scheduler.

3.7.10 DIA Config Service

Configuration parameters concerning the Configuration Service:

• Configuration folder: Path to the configuration files. Do not change this path
unless there is a special need.

• Storage folder: Path to the storage files. Do not change this path unless there is a
special need.

• Local service: The primary node provides a processing unit by default (true). To
disable it, enter false.

3.7.11 DIA Job Scheduler

Configuration parameters for the Job Scheduler:

• Database Folder: The database of the Job Scheduler is stored by default be-
low the Documents and Settings folders. The default path is C:\Documents and
Settings\user name\Application Data\eCognition\JobScheduler.dat folders. In
some cases the size of the database can exceed 2GB. If necessary, you can change
the storage location by editing the path (for example: C:\Program Files\eCognition
Grid\AdminConsole\Data).

Settings

• Engine status timeout: Time in seconds before the Analysis Engine Software
status is set to timeout. If the Analysis Engine Software answers after the preset
timeout the status is set back to the current status.

• Engine idle timeout: If an instance of the Analysis Engine Software did not re-
ceive any job during a specified time, the engine idle timeout, it will be canceled.
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• Orphan job timeout: When a job is assigned to an instance of the Analysis En-
gine Software, the Job Scheduler takes it out of the job queue and waits until the
Analysis Engine Software comes and takes the job. If that does not occur during a
specified time, the orphan job timeout, the job will be again added to the job queue.

• Days to keep history: Time in days the processing states and result references are
kept in the history. Afterwards they will be deleted.

3.7.12 Data Management Spooler

Configuration parameters concerning the Data Management Spooler:

• User Name: The user name of the Data Management Spooler user to authorize for
writing results to the storage. The default user name is Administrator

• Password: The password of the Data Management Spooler user to authorize for
writing results to the storage. The default password is admin

• Delete CSV files: By default, .csv files are deleted after spooling (true). If you
want to keep csv result files, for example to use in a spreadsheet, enter false.
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4 About Configuration and
Components

This chapter provides reference information about software components and specific con-
figurations, for example using the software with firewalls.

4.1 Firewall Settings

If you use firewalls, communication problems might occur after installation. This section
describes how to adapt your firewall settings if there is a firewall between eCognition
software components such as:

• eCognition clients
• eCognition Server including eCognition Grid Infrastructure software on the pri-

mary node and eCognition Node software on the processing nodes of the eCogni-
tion Grid

• A file server used as image data and results repository
• A related database
• eCognition License Server Software

eCognition software uses the following default network communication channels:

• Microsoft file share network for data in and output: Ports 445, 437, 438
• Software internal communications on TCP 8184 (Job Scheduler), and TCP 8284

(Configuration Server), and TCP 4002 (Authentication Server). These ports can be
changed by using the Administration Console.

• License communication

4.1.1 Firewalls Between Clients and File Servers or Databases

There may be a firewall between eCognition clients and a file server (used as an image
data and results repository) or a related database. In that case, open the ports for the
Microsoft file sharing network.
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4.1.2 Firewalls Between Clients and Primary Nodes

If there is a firewall between eCognition client machines and the primary node of the
eCognition Server hosting the Job Scheduler open the port TCP 8184, TCP 8284, and
TCP 4002 bidirectionally.

4.1.3 Firewalls Between Primary Nodes and Processing Nodes

Use the same method described in the previous section on firewalls between client and
primary nodes.

4.1.4 Firewalls between License Server Software and Other
Components

Special settings are required for the License Server Software communication. The bidi-
rectional communication runs on different TCP ports.

1. Open all license files stored on the machine hosting the License Server Software.
The default path is /opt/eCognition License Server <version number>/License
file.lic.

2. Example of a license file header:
• SERVER localhost DISK_SERIAL_NUM=abcdefg [{COMPort_1}]
VENDOR DIALIC [PORT={ComPort_2}]
...

Adapt the license file concerning the two necessary ports:
– The default COMPort_1 is 27000. If you select another value than 27000

you have to adapt all eCognition floating.lic files located in the software
installations manually. For details see step 3.

– Choose a port of your choice for ComPort_2.
3. If you changed the value of COMPort_1 in step 2 you have to change all floating.lic

files, which are part of each eCognition software installation, such as:
• eCognition Grid Infrastructure software on the primary node
• eCognition Node software on processing nodes
• eCognition Developer 8.64.0 clients.

For each eCognition installation, open the floating.lic file. The default path is
C:\Program Files\eCognition [Software name, Version number]\bin\lic\floating.lic.

The adaption of floating.lic files is not supported by the installer. During eCognition
installations, you have to select Set Licensing Later on the Select the Licensing Option
screen.

1. Example of a floating.lic file:
• SERVER [license server IP or DNS name] ANY [{COMPort_1}]
USE_SERVER

Change the COMPort_1 manually to the same value as used in step 2.
2. Open the firewall for port COMPort_1 and COMPort_2.
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4.2 About Configuration Settings

To meet specifics of your system environment, you can modify the default configuration
settings of your eCognition setup. They are stored in the following configuration files:

• eCognition.cfg
• JobSchedulerUsers.xml

4.2.1 eCognition.cfg

The configuration settings stored in the eCognition.cfg file are related to:

• eCognition services
• Primary nodes
• Processing nodes
• eCognition clients
• Image Proxy Server

With the exception of the Image Proxy Server, all configuration settings should be main-
tained using the Administration Console only do not edit the eCognition.cfg file manually.

Image Proxy Server Configuration

It is normally not necessary to modify the configuration of the Image Proxy Server after
installation. In case you need to do so, you would need to manually edit the .cfg on
the primary node and manually copy it to the processing nodes (table 4.1, Image Proxy
Server Configuration). Since this is an advanced option, we would recommend speaking
with Trimble support before doing this.

4.2.2 JobSchedulerUsers.xml

The configuration settings stored in the JobSchedulerUsers.xml configuration file are re-
lated to the DIAJobScheduler and support the user management.

To modify these configuration settings,1 edit JobSchedulerUsers.xml with a text editor –
this file is stored in the installation directory of the primary node of your eCognition Grid.
The default path is C:\Program Files\eCognition [Version number]\bin\config.

• user name=“ ”: Set the Windows user name. When a client sends a job to the Job
Scheduler, the Windows user name of the client user is transmitted as well.

• priority=“ ”: Set the initial priority for analysis. The priority is an integer value. A
high value means high priority. Unknown users are set to 0 priority as default. If a
user is currently running projects on the cluster, the number of the current projects
in progress are subtracted from this priority:

priority = priority [Number of projects that are in progress]

1. If you change the configuration on a running system you must restart the Control Service.
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Table 4.1. Image Proxy Server Configuration

Name Value Description

Mode desktop Desktop

Central

Caching cluster None

Local
Cluster

Caching package ImageCache.1.2.last The version of the image server

Central storage False Image cache is stored on the Image
Proxy Server cache when false.

Max caching processes 4 The number of concurrent threads
that may be started for caching. 1
for desktop and 4 for central mode.

Cache buffer 256 Memory (MB) used by caching
process for buffering

Central storage location C:\Documents and
Settings\All
Users\Application
Data\eCognition Img
ProxyServerCache

The location of the cache data.

Max cache size 10 The maximum storage size of the
cache (GB)

Delete cache older 720 After this number of hours the
cached item will become eligible for
deletion.

Keep cache younger 60 The number of minutes that items
should always be kept in the cache.

Preferred compression jpeg The default image compression
technique. Can also be zlib.

Jpeg quality 100 The quality. 100% equals lossless.
Set range 30–99%.

30 November 2010 Installation and Administration Guide



About Configuration and Components 75

Example for Both Parameters

<user name="User1" priority="10"/>
<user name="User2" priority="1"/>
<user name="User3" priority="100"/>

User1 sends 20 projects into a cluster of 10 instances of Analysis Engine Software, occu-
pying all instances of Analysis Engine Software. User1’s current priority will go down to
zero.

Meanwhile another user, User2, sends 20 projects into the same cluster. All instances of
Analysis Engine Software are still occupied by User1. User2 is on idle until one project
of User1 is finished. When the project is finished one project of User2 will be processed.
The priority of User2 will fall back to zero. The priority of User1 becomes 1.

Now, a third user, User3, sends 20 projects into this cluster. If an instance of Analysis En-
gine Software finishes processing the current project it will then start processing projects
from User3 due to this user’s high priority. The lowest priority User3 can reach is 90. In
this case, User3 will always have the highest priority in comparison to other users, whose
projects will remain in an idle mode until all projects from User3 are completed.

4.3 eCognition Executable Files

In the following sections, the available eCognition executable files are discussed in more
detail.

4.3.1 DIAClient.exe

The eCognition client provides the different user interfaces of eCognition software. The
executable file DIAClient.exe is located in the installation path\bin folder. Products based
on DIAClient.exe are:

• eCognition Architect 8.64.0
• eCognition Developer 8.64.0

You can select a specific client product by invoking DIAClient.exe with the command line
switch /product “client name”. Starting a specific client product requires an appropriate
license.

4.3.2 Data Management Spooler

The Data Management Spooler is a component of the eCognition Grid Infrastructure
software installed on the primary node in the eCognition Grid. It is responsible for storing
analysis results into the data management storage system.

The Data Management Spooler works with selected storage systems. If more storage
systems are used then separate Data Management Spooler has to be started for each. This
can be achieved by using the Administration Console.
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The Data Management Spooler observes the Job Scheduler. When new job coming from
selected storage gets processed, the results are immediately stored in the storage. The
executable file is called DIASpooler.exe and is located in the installation installation
path\bin folder.

4.3.3 Analysis Engine Software

The Analysis Engine Software is the analysis core of the eCognition processing system.
It executes rule sets on projects, retrieves results, reads input data and writes output data
to the storage layer using the data I/O interface.

The Analysis Engine Software is part of the eCognition Node software that can be in-
stalled on a processing node of an eCognition Grid.

The executable file is called DIAEngineService.exe and is located in the installation
path\bin folder. After installation, changes to the settings of the Analysis Engine Soft-
ware can be made using the Administration Console.

4.3.4 Job Scheduler

The Job Scheduler is a component of the eCognition Grid Server Software providing
an integrated HTTP server used for queuing and handling user jobs. It is also used by
the eCognition Node Software for requesting jobs for processing. The Job Scheduler
performs the submitting and monitoring of eCognition Server jobs. It distributes analysis
jobs to Analysis Engine Software on connected processing nodes of an eCognition Grid.

The Job Scheduler is installed on the primary node of an eCognition Grid and is
implemented as a lightweight HTTP server. By default it listens to the port 8184.
You can check the status of the Job Scheduler by connecting your HTML browser to
http://hostmachine:8184.

The executable file is called DIAJobScheduler.exe and is located in the installation
path\bin folder. After installation, changes to the configuration settings can be accom-
plished by using the Administration Console.

NOTE: While working with Windows XP Remote Desktop on a remote
machine that has the Job Scheduler installed, take care not to use the op-
tion /console (for example, %SystemRoot%\system32\mstsc.exe not
%SystemRoot%\system32\mstsc.exe\console). This would restart the
Job Scheduler with every log-on or log-off.

4.3.5 Control Service

The Control Service is a component of the eCognition Node software used as over-
seer for the processing. For processing it startsfrom within Windows Service Man-
ager – the Job Scheduler and the Configuration Service. The executable file is called
DIAControlService.exe and is located in the installation path\bin folder.
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This DIAControlService.exe will be installed as a service on a Windows-based server
machine to control the Analysis Engine Software instances on this machine. After instal-
lation changes to the settings of the Control Service can be achieved using the Adminis-
tration Console.

The Control Service starts the Job Scheduler and the Configuration Service; therefore the
user who started the Control Service needs to have the same access rights for the Analysis
Engine Software as for the Control Service due to heritage of access rights. In addition,
the user needs to have the appropriate access rights for the file storage.

4.3.6 Configuration Service

The Configuration Service is a component of the eCognition Node software used as
provider of the configurations. It provides the processing nodes with the appropriate
software for processing data.

The executable file is called DIAConfigService.exe and is located in the installation
path\bin folder. After installation, changes to the settings of the Configuration Service
can be made via the Administration Console.

4.3.7 eCognition Grid Admin Console Service

The eCognition Grid Admin Console service is a component of the eCognition Grid In-
frastructure Software. It administers the eCognition Grid using a web browser-based
interface.

To open the Administration Console, go to the Windows Start menu and choose Start >
All Programs > eCognition Grid > Admin Console. Your web browser display the log
in page of the Administration Console. The executable file is called mongrel_service.exe
and is located in the installation path AdminConcole\ruby\bin folder.

4.3.8 File Storage

The file storage is the repository for image data, results, workspaces, projects, and rule
sets. It is accessed by shared folders via network.

The file storage must provide simultaneous access for all instances of the Analysis Engine
Software. This is usually not possible when using Microsoft Windows workstation as
it provides only a restricted access to their file system over the network. We strongly
recommend using a file server as image repository.

If you are using Data Management, the following will apply, and users can also use a file
system when disconnected from a database, if desired.

• Images and the associated image results must be stored outside the database.
• Image analysis statistics are stored inside the database.
• Workspaces are stored inside the database.
• Rule sets may be located either inside or outside the database.
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5 Frequently Asked Questions

Answers to commonly encountered installation problems.

5.1 System Communication Problems

Q: After setting up an eCognition system on multiple machines, there are problems with
the system communication.

A: You need to adapt your firewall settings if there is a firewall between eCognition
software components such as:

• eCognition clients
• eCognition Server
• A file server used as image data and results repository
• A related database
• eCognition License Server Software

5.2 Removing eCognition Control Services Manually

Q: Can I remove the eCognition Control Service from the Windows service control man-
ager manually?

A: You need to have the service installation right on the machine you are accessing.

• Local: Use the following commands in the command prompt window:
– sc stop [eCognition Control Service Version number]
– sc delete [eCognition Control Service Version number]

• Network server: Use the following commands in the command prompt window:
– sc \\server name stop [eCognition Control Service Version number]
– sc \\server name delete [eCognition Control Service Version number]

5.3 Using a Dual Processor

Q: I use a dual processor machine. Why is the load of the processor only around 50%
during the analysis?
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A: A single project can be only processed on a single CPU. However, Windows switches
the load between both CPUs; this is the reason for the reduced processor load. If you
start a second analysis instance on a second project, then the load of both processors will
be 100%.

5.4 How Can I Observe the Status of the eCognition
Server?

Q: How can I monitor the status of processing and waiting jobs?

A: A status page provides information about attached analysis engine
and waiting jobs. To access the status page of the Job Scheduler go to
http://[Name of the Processing Network Node]:8184

5.5 Job Scheduler on Remote Machine Always Restarts

Q: The Job Scheduler restarts every time I log off the remote machine that has the Job
Scheduler installed. How can I stop this?

A: While working with Windows XP Remote Desktop on a remote
machine that has the Job Scheduler installed, do not use the op-
tion /console (for example, %SystemRoot%\system32\mstsc.exe not
%SystemRoot%\system32\mstsc.exe /console).

5.6 Rounding of Floating Point Numbers

The rounding of floating point numbers depends on the operating system and runtime
libraries. Therefore the results of statistical calculations between Linux and Windows
may be slightly different.
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required to include the following text, with software and distributions.

The Visualization Toolkit (VTK) Copyright

This is an open-source copyright as follows:

Copyright © 1993–2006 Ken Martin, Will Schroeder and Bill Lorensen.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

• Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright notice, this list
of conditions and the following disclaimer in the documentation and/or other mate-
rials provided with the distribution.

• Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names of
any contributors may be used to endorse or promote products derived from this
software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CON-
TRIBUTORS ‘AS IS′ AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUD-
ING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABIL-
ITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR ANY DI-
RECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTI-
TUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLI-
GENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

ITK Copyright

E

Copyright © 1999–2003 Insight Software Consortium

All rights reserved.
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Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following conditions are met:

• Redistributions of source code must retain the above copyright notice, this list of
conditions and the following disclaimer.

• Redistributions in binary form must reproduce the above copyright notice, this list
of conditions and the following disclaimer in the documentation and/or other mate-
rials provided with the distribution.

• Neither the name of the Insight Software Consortium nor the names of its con-
tributors may be used to endorse or promote products derived from this software
without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CON-
TRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUD-
ING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABIL-
ITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSE-
QUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUD-
ING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAM-
AGE

Copyright © Trimble Navigation Ltd
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